Indlejrede HVIS funktioner i Excel

HVIS funktioner i Excel

GUIDE: HVIS funktioner i Excel


Med indlejrede HVIS funktioner kan der håndteres mange forskellige tilfælde. En funktion bruges som argument for en anden funktion, og det er muligt at indlejre op til 64 HVIS funktioner.

I det følgende eksempel skal der angives om en værdi er for lav, godkendt eller for høj. Eksemplet kan illustreres således:

Da funktionen skal kunne kopieres, er det en fordel at navngive cellerne med grænseværdierne (navngivne celler er absolutte referencer). Regnearket kan se således ud:

I celle D2 indsættes HVIS funktionen:

Feltet Logist_test              Test om værdien er mindre en grænsen: C2<GrænseLav

Feltet Værdi_hvis_sand    Når værdien er mindre en grænsen, skal der vises en tekst:
”for lav”

Feltet Værdi_hvis_falsk    Her skal der indlejres en ny HVIS-funktion, hvilket gøres ved at vælge den ønskede funktion i Boksen Navn, til venstre for formellinjen.

Denne har en anden funktion end at vise cellereferencer, når der indtastes funktioner, det er nemlig her muligt at vælge, hvilken funktion der skal anvendes som argument til den igangværende funktion. Hvis den funktion der skal anvendes som argument er den samme, som man er i gang med at udfylde, kan der blot klikkes på Boksen Navn, hvor den aktuelle funktions navn vil stå.

Er det en anden funktion der skal indsættes, klikkes på dropdown pilen til højre for funktionsnavnet, og man kan vælge mellem de 10 sidst anvendte funktioner. Findes den ønskede funktion ikke blandt disse, vælges punktet Flere Funktioner..., dette svarer til at vælge Indsæt funktion, og man har her adgang til alle Excels funktioner. I dette eksempel er det den samme funktion der skal anvendes, så her klikkes på funktionsnavnet HVIS, og man får en formelpalette magen til den, man lige har udfyldt.

Efter den er udfyldt skal den se således ud:

Når formelpaletten er udfyldt klikkes OK og formlen vil se ud som nedenfor:

=HVIS(C2<GrænseLav;"for lav";HVIS(C2<GrænseHøj;"godkendt";"for høj"))

-

-

Kombinationen af flere HVIS’er kan være en kompliceret konstruktion. Der er imidlertid et par gode råd, som kan hjælpe dig, hvis du oplever det som værende meget uoverkommeligt at opbygge disse sammensatte funktioner.

Det første råd er:

·       Undgå sammenblanding at den logiske og den matematiske del af problemstillingen

Hvis du fx skal beregne en niveaudelt rabat, hvor man ingen rabat får for indkøb op til ti stk, 5% ved køb af op til 15 og 10% ved køb af alt over 15, så skal du opløse problemet i en logisk del, hvor du tester for ingen rabat under 11, for lille rabat for under 16 og stor rabat for resten. Brug i første omgang tekst i HVIS-formeln: ”Ingen rabat”, ”Lille rabat” og ”Stor rabat”. Efterfølgende kan du erstatte teksten med selve kalkulationen.

Det andet råd:

·       Optæl antallet af muligeder for at overskue antallet af HVIS’er

Antallet af muligheder minus én er lig antallet af HVIS’er, eller Muligheder -1 = Antal HVIS’er.

Eksemplet herover (Ingen rabat, Lille rabat, Stor rabat) har tre muligheder, derfor skal du bruge to HVIS’er.

=HVIS(C2<11;"Ingen rabat";HVIS(C2<16;"Lille rabat";"Stor rabat"))

Det tredje råd:

·       Test altid grænseværdier

Eksemplet herover bør afprøves på 10,11, 15 og 16

Formlen kopieres og resultatet i Excel er således ud:


Gå til Excel kurser
Se flere guides, tips & tricks